Take note: OverDrive security update could impact your device

If you use OverDrive through the Library to check out eBooks, eAudiobooks, eMagazines and more, you should know about upcoming security changes with the service.

You may have seen a message on the OverDrive app or on the OverDrive website about this upcoming change.

Here's what you need to know so you can continue to access digital library materials on OverDrive after October 30.

Which devices are impacted?

These devices were released in 2014 or earlier:

  • Android (Version 5)
  • Early Kindle Fires
  • Early Samsung Galaxy tablets
  • Kobo Arc devices

What's the timeline?

  • October 30, 2020: OverDrive will end support for TLS 1.0 and 1.1.
  • After October 30, 2020: The OverDrive app and OverDrive websites will no longer work on devices that don't support TLS 1.2.

What do I need to do?

To continue to use the OverDrive app or the OverDrive website on your device, affected customers will need to either update their device's operating system (if possible) to a version that supports TLS 1.2 or switch to a device that supports TLS 1.2.

You can also choose to only update your device's browser to a version that supports TLS 1.2, which will allow you to use OverDrive websites in your browser. If you use this method, you won't be able to use the OverDrive app.

Please note: Current Libby users on Android devices should not be impacted, as Libby’s minimum system requirements were already raised to Android 5 in June 2020.

Also, users of early Kindle Fires and Kindle eReaders that don't support TLS 1.2 will still be able to transfer and read Kindle format ebooks using your devices. You just won’t be able to download ePub formats to the OverDrive app on your device.

Why is OverDrive making these changes?

OverDrive is updating their data protection and security protocols, which includes upgrading to more current technologies that offer more secure standards. Because of these upgrades, OverDrive will no longer be able to support older devices that do not meet the newer standards.

What are the nitty-gritty tech details?

OverDrive will end support for devices that use the outdated TLS 1.0 and 1.1 security protocols. TLS (Transport Layer Security) is the technology that keeps data private when it is sent over a secure (https) internet connection. TLS versions 1.0 and 1.1 date back to 1999 and 2006, respectively, and have since been replaced on most devices by TLS 1.2, which addresses weaknesses and vulnerabilities in the earlier versions. At OverDrive, TLS protects the privacy of your data, including library card information.

If you have further questions, please contact the Library's Virtual Information Center at 513-369-6900. Our staff is also available through chat or text!

We welcome your respectful and on-topic comments and questions in this limited public forum. To find out more, please see Appropriate Use When Posting Content. Community-contributed content represents the views of the user, not those of Cincinnati & Hamilton County Public Library